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1. GETTING STARTED 

1.1. Pre-requisites 

It is assumed the instrument is correctly set up according to the relevant User Manual. 

The controller operates on Windows 10 IoT Enterprise LTSC. To ensure stability, it does not 

install Windows updates automatically. Keit recommends running Windows updates before 

setting up the IRmadillo. 

KeitSpec should only be run in the Spectrometer User account. The IRmadillo can connect to 

only one instance of KeitSpec. If KeitSpec is opened in another user account, it will not connect 

to the spectrometer. 

1.2. The Spectrometer tab: an overview 

When the controller powers on, KeitSpec automatically loads with the Spectrometer tab open. 

It will connect to the IRmadillo and open the last used project file. The IRmadillo comes with a 

factory background scan that loads automatically. 

Before you start taking spectral measurements, it is important to ensure that the spectrometer 

is connected, is stable and is purged. Look for the following indicators: 

 

Figure 1: The Spectrometer tab 

 

1. Spectrometer Status indicators 

The following indicators may be shown: 

Green tick: IRmadillo is connected and is thermally stable. 

 Red thermometer icon: IRmadillo is connected but is not yet thermally stable. 

Wait for the IRmadillo to stabilise before taking any measurements. 
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 Red cross: IRmadillo an error. Refer to the troubleshooting section of the 

IRmadillo User Manual. 

 Black arrows: IRmadillo is not connected 

 

  Not saving icon: IRmadillo is not autosaving data  

 

Before collecting data, ensure that the green tick is showing, and that the status is 

óSpectrometer OKô. 

 

2. Errors and Warnings pane 

Displays any errors or warnings on the IRmadillo. It should read "No Errors or Warnings." 

If not, refer to the troubleshooting section of the IRmadillo User Manual. 

 

3. Spectrum view 

Displays the live spectrum from the IRmadillo, updating every ten seconds. 

 

4. Water vapour absorbance region 

Water vapor peaks appear between 1350 cmϖ¹ and 1700 cmϖ¹. Broad peaks in this region 

suggest a poor air purge; check the IRmadillo User Manual. Narrow peaks elsewhere 

indicate the probe's sensing ATR element needs cleaning and drying. Refer to DOC0935 

for guidance. 
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1.3. Collecting spectra in a continuous process 

These steps guide you in creating a new continuous collection project, collecting a background 

spectrum, and selecting settings. For measuring individual spectra of discrete samples, see 

Section 1.9 Manual sampling. 

1. Create a new continuous project by clicking the purple folder icon in the top left, then 

choose Create New Empty Project > Continuous Collectioné 

 

 

Figure 2: Creating a new Empty Continuous Collection project 

 

2. In In the window that opens, navigate to the desired location, enter a project name, 

and click OK. 

 

 

Figure 3: Creating a new Continuous Collection project 
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3. Record a background spectrum. Keit recommends a 30-minute air scan. Ensure the 

probe ATR element is clean. Adjust the scan duration using the Time to Collect 

Background inputs. 

 

 

Figure 4: Changing background spectrum collection settings 

 

Next, click Background Scan > Collect New Background. 

 

 

Figure 5: Recording a new background spectrum 
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The Background Scan button turns green, and a progress bar at the bottom right shows 

the scan's progress. Once completed, the button returns to white. Note: background 

scan collection cannot be cancelled once started.  

 

Figure 6: Recording of a new background spectrum in progress 

 

4. You're now ready to collect spectra. On the Configure Acquisition tab, set the Scan 

Averaging Duration (default is 120 seconds). 

For details on the Data Communications Methods panel, see Section 1.8. 

The instrument will start recording spectra automatically once a valid background is 

detected. 

 

Figure 7: The Configure Acquisition tab 
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5. View spectra in real time on the Spectrometer tab. Interactive graphs display changes 

in absorbance and spectral power over time. A table in the bottom right corner provides 

the spectrometer's status.  

 

Figure 8: Viewing of incoming spectra  



 Page 10 

 

DOC0893 KeitSpec Software User Manual (28 March 2025 11:17) 

www.keit.co.uk Back to Table of Contents  

1.4. Loading a univariate model 

Loading a univariate model allows you to see how a spectral region evolves over time. It is 

simpler and less informative than the chemometric models described in Section 1.5 but can 

be useful for some applications. 

1. On the Configure Acquisition tab, click the Configure button. 

 

Figure 9: Loading a chemometric model 

 

2. A Chemometrics Editor window will open. Click the + icon on the left of the screen to 

open a menu of model types and select Add New Model>> Univariate. This will open 

an Edit Univariate window. 

 

Figure 10: The Chemometrics Editor 
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3. In the Edit Univariate window, use the Min and Max inputs to set the wavenumber 

range. Checkboxes allow you to toggle whether the Maximum, the Average and the 

Minimum are reported. When you have made your selection, click OK to load the 

model. 

 

 

Figure 11: Editing a Univariate model 

 

4. A model of type Univariate should now be loaded into the Chemometrics Editor 

window. When this model is selected, its details will be shown in the bottom panel.  

Additional models can be added using the + button as before. Models can also be 

deleted by right-clicking on a model and selecting Delete this Model. When you have 

added all your models, click Done to close this window. 

Click Done to finish. 

 

 

Figure 12: Applying a Univariate model 
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1.5. Loading a chemometric model 

Chemometric models allow you to view an interpretation of the spectra in terms of 

concentrations of chemical species, or diagnostic statistics of the collected spectra, in real 

time. 

1. On the Configure Acquisition tab, click the Configure button. 

 

Figure 13: Loading a chemometric model 

 

2. A Chemometrics Editor window will open. Click the + icon on the left of the screen to 

open a menu of model types and select the type of chemometric model to add. In this 

example we will use a PLS Toolbox (Solo_Predictor) model (see Section 3.1 

Configure Chemometrics for more information about available model types). Click the 

model type and, when the file explorer window opens, navigate to the model you want 

to load and click OK. 

 

Figure 14: The Chemometrics Editor window 
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3. A model can report several features of the spectra. In this example, the features are 

the DP3+ measurement, the Hotellingôs T2, and the Q residuals. Select the features to 

report by checking or unchecking the boxes. Check that the desired outputs are listed 

in the description window, then click OK when done. This will close the window. 

 

 

Figure 15: Adding a Solo_Predictor model 

 

4. Additional models can be added using the + button as before. Models can also be 

deleted by right-clicking on a model and selecting Delete this Model. When you have 

added all your models, click Done to close this window. 

 

 

Figure 16: Adding an additional chemometric model 
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5. The outputs of the model are now displayed in the Chemometrics panel. These values 

update in real time as spectra are collected. 

 

Figure 17: The Chemometrics panel 
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1.6. Filtering 

To reduce noise, consider applying an exponential filter to the IRmadilloôs predictions, 

depending on your process dynamics and chemistry changes.  

1. Open the Chemometrics Editor. This window shows all models currently loaded on 

your system and includes the Display Filtering column.  

 

Figure 18 Display Filtering Column 

2. Double-click the model in the Display Filtering column to edit the Display Filtering 

Times. This opens the Edit Display Filtering Times window:  

 

Figure 19 Edit Display Filtering Times 
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3. In the Edit Display Filtering Times window, enter the filter time constant in seconds. 

The example shows 10, 15, and 20 minutes. Press OK when done. 

 

4. The filtering time constant will appear in the Display Filtering column. Click Done to 

apply the filters.  
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1.7. Exporting data 

Data recorded by the spectrometer and processed by the models can be exported as a text 

file. 

1. Open the Project Data Viewer tab. The model outputs are shown in an interactive 

graph (top panel), which you can explore using the buttons in the top left corner. The 

spectra are displayed in the bottom panel.  

 

Figure 20: The Project Data Viewer tab 

 

2. You may wish to mark time points in an experiment. To do this, right click the interactive 

graph in the top panel at the point you wish to mark. A menu will open allowing you to 
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Set Marker Here. Clicking this will open a new window prompting you to name the 

time point. 

 

Figure 21: Adding a Marker 

 

3. To export the data, click the Export button on the right of the screen. 

 

 

Figure 22: Exporting data 

 

4. Selecting Export Metrics to TXT File will open a second menu allowing you to export 

either the model outputs currently displayed in the graph (As Viewed) or the entire 

dataset (All Data). Click your preference and a window will open, allowing you to 

navigate to the desired location to save your file. 
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Figure 23: Exporting chemometric predictions 

 

5. Similarly, selecting Export Spectra to File will open a menu to export only Spectra in 

View Range, All Spectra, or only Marked Spectra. 

1.8. Connecting to control system (DCS or PLC) 

KeitSpec provides four methods for data to be exported in real time: 

¶ Modbus RTU Slave (models ASM0627-xx-x-x-O-x-x only) 

¶ Modbus TCP Server 

¶ OPC-UA Server 

¶ Autosave to Folder 

These can be activated configured on the Configure Acquisition tab in the Data 

Communication Methods panel. Toggling the switches from OFF to ON adds new tabs to 

the main window. 

1.8.1. Modbus RTU Slave 

1. To enable Modbus RTU Slave, toggle the Modbus RTU Slave switch. This will create 

a new tab at the top of the window. 
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Figure 24: Enabling Modbus RTU Slave 

 

2. Open the Modbus RTU Slave tab. A list of Input and Holding Registers is given on the 

panel on the right-hand side, showing the various outputs and their addresses. To 

enable the connection, toggle the Enable Slave switch to the ON position. The text 

below will show Connected when the connection has been made. 

 

 

Figure 25: The Modbus RTU Slave tab 

 

3. For further details on connecting via Modbus RTU, refer to DOC0871 Commissioning 

Guide - data communication - Modbus RTU. 
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1.8.2. Modbus TCP Server 

1. To enable Modbus TCP Server, toggle the Modbus TCP Server switch. This will 

create a new tab at the top of the window. 

 

 

Figure 26: Enabling Modbus TCP Server 
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2. Open the Modbus TCP Server tab. A list of Input and Holding Registers is given on 

the panel on the right-hand side, showing the various outputs and their addresses. To 

enable the connection, toggle the Enable Server switch to the ON position. The text 

below will show Connected when the connection has been made. 

 

Figure 27: The Modbus TCP Server tab 

 

3. For further details on connecting via Modbus TCP, refer to DOC0817 IRmadillo 

Commissioning Guide ï data communication ï Modbus TCP/IP. 

1.8.3. OPC-UA Server 

1. To enable OPC-UA Server, toggle the OPC-UA Server switch. This will create a new 

tab at the top of the window. 

 

Figure 28: Enabling OPC-UA Server 
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2. Open the OPC-UA Server tab. To enable the connection, toggle the Enable OPC-UA 

Server switch to the ON position. The text below will show Connected when the 

connection has been made. 

 

Figure 29: The OPC-UA Server tab 

 

3. For further details on connecting via OPC-UA Server, refer to DOC0828 IRmadillo 

Commissioning Guide ï data communication ï OPC-UA. 

1.8.4. Autosave to Folder 

1. To enable autosaving to folder, toggle the Autosave to Folder switch. This will create 

a new tab at the top of the window. 
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Figure 30: Enabling Autosave to Folder 

 

2. Open the Autosave to Folder tab. The panel bounded by a blue rectangle allows you 

to navigate to a folder to save data into. The Enable Saving toggle enables automatic 

saving to the folder selected. 

 

 

Figure 31: The Autosave to Folder tab 

 

3. For further details on connecting via a watched folder, refer to DOC0876 IRmadillo 

Commissioning Guide ï data communication ï Watched Folder. 
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1.9. Manual sampling 

These steps lead you through the process of creating a new manual sample acquisition project 

and how to collect spectra manually. 

1. Create a new manual project by clicking the purple folder icon in the top left corner, 

then choose New Project > Manual Sample Acquisitioné 

 

 

Figure 32: Creating a new Manual Sample Acquisition project 

2. In the window that opens, navigate to the desired location and enter a name for your 

project. Click OK to create the project.  

 

3. You should next record a background spectrum. Keit recommends a 30-minute 

background scan of air. Ensure that the probe ATR element is clean before doing so. 

The background scan duration can be adjusted using the Time to Collect 

Background inputs shown below. 
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Figure 33: Changing background spectrum collection settings 

 

Next, click Background Scan > Collect New Background. 

 

 

Figure 34: Recording a new background spectrum 

 

The Background Scan button will turn green and a progress bar at the bottom right 

of the window will show the progress of the background scan. When the background 

scan has completed, the Background Scan button will return to its original white 

colour. Please note that background scan collection cannot be cancelled once it has 

been started. 
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Figure 35: Recording of a new background spectrum in progress 

 

4. You are now ready to collect spectra. On the Sample Acquisition tab, enter the name 

of the sample you are measuring and set the time to scan and number of samples. 

Keit recommends scanning for 120 seconds and taking three samples.  

 

 

Figure 36: Collecting Manual Samples 

5. Place your sample on the probe tip. Click the blue Collect Sample button or press F1 

to collect samples. The Collect Sample button will go green during sample collection. 
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6. Spectra can be viewed once they have been saved in the Sample Acquisition tab. Click 

on a sample in the table to display its spectrum on the plot. You may select and display 

multiple spectra by ctrl+clicking or shift+clicking. 

 

 

Figure 37: Viewing Manual Samples 

 

7. To export the spectra of manual samples to a text file for import into a chemometrics 

modelling program, click the Export button, then select Export Spectra to File > All 

Spectra. 

 

Figure 38: Exporting spectra  
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2. THE SPECTROMETER TAB 

The Spectrometer tab provides setup information and ensures the instrument is working.

 

Figure 39: The Spectrometer tab 

1. The File menu 

a. Create New Project from existing Project: Creates a new project file of the same 

type (Continuous/Manual), copying all models, settings, and the background from 

the current open project file. 

b. Create new Empty Project: Creates a new empty project file (either Manual 

Sample Acquisition or Continuous Collection).  

c. Save Copy of current Project (including data): Creates a copy of the current 

project, including all spectral data. This is the safest way to duplicate a project; 

copying in your file browser while the project is open in KeitSpec may corrupt the 

project file.   

d. Open Project: Opens a project from disk. The project's background spectrum will 

replace the current background (if any). Use the Background Scan button options 

to load or collect a different background spectrum. 

e. Close Project: This option can be used to safely close a project. 

 

2. Context help 

Context help appears in a floating window, providing information about the control or 

display the mouse pointer is hovering over. Use this feature to learn more about the 

software interface controls. 
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3. More options 

a. Spectrometer Action 

i. Reset Spectrometer: If the spectrometer stops responding, reset it using 

this dropdown. 

ii. Reenable Sagnac TEC: For some older models of IRmadillo (ASM0627-xx-

x-A-x-x-x), exceeding the operating temperature range can damage 

electronics. Thermal stabilization will shut down automatically, and an error 

will appear in the Data Integrity pane (item 3110). Restart thermal 

stabilization when the IRmadillo returns to its specified temperature range.  

b. Change Timezone: Allows the user to change the timezone in which the project file 

is saved. 

c. Create data package for Health Check: Keit offers an annual health check as part 

of the IRmadilloôs Maintenance and Support Programme (MSP). This control 

gathers the necessary files for Keit to perform the health check. To enrol in the MSP, 

contact your sales representative.  

 

4. Background scan 

FTIR requires a background spectrum (reference scan) before measuring absorption. 

Collect the background spectrum before inserting the probe into the reaction or process.  

a. Collect New Background: Collects a new background spectrum for the duration 

that is given in the Time to Collect Background boxes. 

b. Load Background from other Project file: Loads the background spectrum from 

another project file. 

c. Save Background to KeitData file: Saves the background spectrum in Keitôs data 

format. 

d. Export Background to Text file: Saves the background spectrum as a human-

readable text file. 

e. Export Background to SPC file: Saves the background spectrum as an SPC file. 

f. Load Background from KeitData file: Loads a background spectrum that has 

been saved in Keitôs data format. 

g. Load Background from Autosaved History Folder: Background spectra are 

automatically stored on the IRmadilloôs controller. This control allows these 

backgrounds to be reloaded into KeitSpec. 

 

5. Cleaning Mode 

Manual Cleaning Mode returns spectra every 2 seconds, useful for cleaning the probe tip. 

In this mode, spectra are not analyzed, stored, or reported via DCS. To return to Normal 

Running Mode, click 'Dismiss' or close the window.  

6. Standby Mode 

Standby mode disables the emitter (infrared light source) in the probe. 

7. Spectrometer Status 

Shows the status of the spectrometer. For more information, see Section 1.2 The 

Spectrometer tab: an overview. 
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8. Simulated Mode 

Uses simulated data, allowing you to learn the software without a spectrometer. 

9. Spectrum 

Displays the current raw spectrum, absorption spectrum, and background reference 

spectrum. Use the top-left controls to zoom in on a specific spectral region.  

10. Data Integrity pane 

The spectrometer performs internal diagnostics to ensure reliable measurements. Any 

compromising conditions are shown in this panel, such as the instrument warming up. For 

more details, see Section 10 Troubleshooting. 

11. Spectrometer health chart 

Shows the metric that has been selected in the spectrometer health table. 

12. Spectrometer health table 

Relevant spectrometer performance metrics are shown in this table. Selecting a row plots 

the recent history of that metric in the spectrometer health chart. 

13. Status bar 

Instrument information appears in this bar, such as whether a background spectrum is 

loaded or if data is being collected. The status bar may show ó(Calibration transfer 

disabled)ô, referring to a spectral space transform technique. For most applications, 

calibration transfer between spectrometers is best done by augmenting the calibration with 

spectra from the second spectrometer. Some specialized applications benefit from using 

a spectral space transform on live data. Keit will advise on the best calibration transfer 

method during the calibration process if purchasing multiple instruments. 

14. Progress bar 

Shows the progress of the current scan. 
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3. CONTINUOUS COLLECTION: THE CONFIGURE ACQUISITION 

TAB 

When you create a new project file in Continuous Collection mode, the Configure Acquisition 

tab will appear. This allows you to change the settings for data collection. 

 

Figure 40: The Continuous Acquisition tab 

1. Scan Averaging Duration 

This sets the length of time for which spectra are averaged. Keit recommends averaging 

for 120 seconds for most applications. 

2. Project Data Viewer toggle 

When turned on, the Project Data Viewer tab will appear. This allows you to look at trends 

in the spectra over time. See Section 4 The Project Data Viewer tab for more information. 

3. Data Communication Methods 

KeitSpec can communicate data externally by four different methods: Modbus RTU 

(models ASM0627-xx-x-x-O-x-x only), Modbus TCP, OPC-UA (subject to the purchase of 

a separate OPC-UA licence), and by saving spectra to a folder over your local network. 

Use these toggles to enable the communication method(s) that are required. 

4. Background collection time 

This gives the date and time at which the background currently in use was collected. 

5. Configure Chemometrics 

KeitSpec includes analysis engines for chemometric models from various external 

software. The Configure Chemometrics button opens a window to adjust these models. 

When a model is loaded or changed, the software recalculates its outputs for all spectra 

in the Project file, which may take time for large files or complex models. See Section 3.1 

Configure Chemometrics for details. 
































































